Welcome to the Loaches Online Forum Archives, full of historical information on loaches and other freshwater tropical aquarium fish from 1998 to 2005. You may want to use the Search Engine to find what you're looking for, or browse the other archives: (Archive 1) (Archive 2) (Archive 3) (Archive 4) (Archive 5) (Archive 6)

Don't forget to visit the new Loach Forum when you're finished!

View Thread | Return to Index | Read Prev Msg | Read Next Msg

The Loach Forum Archives (5)

I was bad...

Posted By: Mr. Leadfoot <leadfoot@sbcglobal.net>
Date: Monday, 15 September 2003, at 7:17 p.m.

... over the weeknd and bought some new fish from one of the Big Two. Of course, I knew better about those ICH Factories, but I took a chance anyway, because I was having a hard time finding male red velvet swordtails at the better LFSes. And, now, of course, I practice what I preach as I climb temps into the high 80's, low 90's. Although no fish in the tank I pulled mine from had any visible signs of ICH, one of the three new fish died within hours after bringing them home. That was around the time a spot appeared. I immediately upped the temps and dosed with Maracide, and within a few hours there are several spots on each fish. I think the rest of the fish will be ok, because I ALWAYS dose the q-tank with Paraguard BEFORE introducing new fish to the water, regardless of if I'm going to battle parasites or not, and I'm fairly certain no parasite is alive in the water to further contaminate the fish.

All the same, I wish myself luck, and vow (again) not to buy any more fish from the Big Two.
 

Messages In This Thread