Welcome to the Loaches Online Forum Archives, full of historical information on loaches and other freshwater tropical aquarium fish from 1998 to 2005. You may want to use the Search Engine to find what you're looking for, or browse the other archives: (Archive 1) (Archive 2) (Archive 3) (Archive 4) (Archive 5) (Archive 6)

Don't forget to visit the new Loach Forum when you're finished!

View Thread | Return to Index | Read Prev Msg | Read Next Msg

The Loach Forum Archives (6)

UV Sterilizer

Posted By: Leadfoot <leadfoot@sbcglobal.net>
Date: Monday, 27 September 2004, at 11:27 p.m.

Hi, all,

I've been gone quite awhile, and now I'm back... with a NEW problem, of course! :-)

I have 6 tanks. My 75 has recently decided to be home of the world's best suspended algae, and I can't seem to get rid of it, even with daily water changes, and even complete lights off!

Interestingly, several months ago I bought a UV Sterilizer for parasite control. At the beginning of summer, I had to keep the sterilizer off because ambient temps had my tank running a constant 88 degrees F! Fortunately, ALL fish survived in this community tank, and my loaches are happeir than sh|t now that the temps are back down to the low 80s.

Anyway, right when the temps dropped back down, the tank's water started becoming pea soup! You would think it should be the other way around, but NOOOOO, of course not...par for the course with me.

OK, so I go to plug the power back into my UZ sterilizer, which was still hooked up with water running through it the whole time, and it doesn't turn on. So, I take it apart, and what do I find? Complete corrosion inside. What brand? You guessed it...CustomSeaDeath, er CustomSeaLife. Still under warranty, but as is the story of my life, the company ran away from its legal responsibilities.

Sooooo.... I'm now in the market again for a UV Sterilizer, specifically to kill this bloomin' algae(pun intended)! I remember a LONG time ago, we hashed the pros and cons of different models here on this forum, and of course, I selected the wrong one, so I am asking for all those who have experience with UV units to share their findings with me.

I'm interested in knowing what units you have that have been dependable for YEARS, and whether or not they will really eliminate suspended algae. Also, what kind of maintenance is required, and how difficult it is.

I am aware that quartz sleeve models are probably best for high UV light penetration, but am worried about cleaning. I also wonder about the safety and dependability of the type of units where the bulb is in direct contact with the water (can you say electrocution?).

The tank designated to receive a UV unit is a 75 freshwater tank with some clowns, a histrionica, two bristle-nosed plecos, a gold nugget pleco, a cactus leopard pleco, tiger barbs, Bosemani and Irian Rainbows and an orange molly. Plants include two 24 inch Amazon swords, rotala and Giant Anubias.

Thanks for any responses. :-)
 

Messages In This Thread